Out of Date Browser

It appears that you are running an older and out of date browser. Our website redesign has taken advantage of all the latest markup and tools available to web developers, which unfortunately means that some older browsers including Internet Explorer 7 and below cannot process our website.

Big Sky Resort requires Internet Explorer 8 or newer. For the best experience and maximum functionality, Internet Explorer 9 or above is strongly recommended. Internet Explorer 9 is available on Windows Vista and newer operating systems.

If you are running Windows XP or newer, check Windows Update for the latest updates. If you're on OS X, check for Software Updates. Also consider upgrading to the newest operating system available for your computer.

If you would rather not update or upgrade your Operating System, you may instead download and install one of these free alternative browsers:

Questions?

Call Us: (800) 548-4486
Or Email: info@bigskyresort.com